Category : onesignal

I have created an application that uses onesignal for notification and now i want to implement firebase for messages in the application but as soon as i implemented google service dependency it gave the error and now i am stuck this my android/build.gradle file dependencies { classpath ‘com.android.tools.build:gradle:3.5.0’ classpath ‘com.google.gms:google-services:4.3.3’ classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version" } this is ..

Read more

I can’t compile my project because of this: FAILURE: Build failed with an exception. * What went wrong: Could not determine the dependencies of task ‘:app:compileDebugJavaWithJavac’. > Could not resolve all task dependencies for configuration ‘:app:debugCompileClasspath’. > Could not resolve com.google.firebase:firebase-messaging:[10.2.1, 17.3.99]. Required by: project :app > com.onesignal:OneSignal:3.15.3 > Failed to list versions for com.google.firebase:firebase-messaging. ..

Read more

I want to send some tags to OneSignal, when i pushing on the notifications. Now, i’m getting a tag in OneSignal, when I haven’t even pushed on it yet. Plese, help me! It’s my an Application.class OneSignal.setLogLevel(OneSignal.LOG_LEVEL.VERBOSE, OneSignal.LOG_LEVEL.NONE); OneSignal.initWithContext(this) OneSignal.setAppId(ONESIGNAL_ID) //обрабатываем нажатие ссылки OneSignal.setNotificationOpenedHandler { result -> result.notification.additionalData?.let { additionalData -> if (additionalData.has("url")) { val ..

Read more

I want to send some tags to OneSignal when I am pushing the notifications. Now, I’m getting a tag in OneSignal, when I haven’t even pushed on it yet. Plese, help me! It’s my an Application.class OneSignal.setLogLevel(OneSignal.LOG_LEVEL.VERBOSE, OneSignal.LOG_LEVEL.NONE); OneSignal.initWithContext(this) OneSignal.setAppId(ONESIGNAL_ID) //обрабатываем нажатие ссылки OneSignal.setNotificationOpenedHandler { result -> result.notification.additionalData?.let { additionalData -> if (additionalData.has("url")) { val ..

Read more

I’m running a flutter project and I’m getting a persistent error involving Google Play Services versioning along with onesignal_flutter dependencies. I’ve found a few answers for react but not Flutter. Please help. FAILURE: Build failed with an exception. * What went wrong: Could not determine the dependencies of task ‘:app:compileDebugJavaWithJavac’. > In project ‘app’ a ..

Read more

I am working in Onesignal in android app and Onesignal few days back update their SDK 4.0.0. I am working in a push notification and that is working fine but now I am want to programmatically enable and disable Onesignal push notification and I know how to achieve this, using below code OneSignal.disablePush(false); As I ..

Read more