Category : import

I’m trying to import a submodule of an android library I’m creating. The sub-module is called progressbar https://jitpack.io/#SomeKoder/Essentials/0.1.0 https://github.com/SomeKoder/Essentials dependencies { implementation ‘com.github.SomeKoder:Essentials:0.1.0′ } I’ve tried this and many other variations without success. dependencies { implementation ‘com.github.SomeKoder.Essentials:progressbar:0.1.0′ } Can someone help me figure out what I’m doing wrong please? Thanks in advance Source: Android..

Read more

Its weird because its working in the implementation, but the editor is highlighting in red the last word of the import (see attached image). And underlining the file as "with errors". On my app gradle I have: implementation fileTree(dir: ‘libs’, include: [‘*.jar’]) implementation ‘com.google.code.gson:gson:2.8.6’ on the other gradle: buildscript { ext.kotlin_version = "1.5.10" repositories { ..

Read more

Hello i am trying to import a library called amulyakhare from github into my android studio project but i keep getting the following error after syncing: Failed to resolve: com.amulyakhare:com.amulyakhare.textdrawable:1.0.1 Show in Project Structure dialog Affected Modules: app You can find the github page of the library here : @github/amulyakhare This is the code in ..

Read more

I’m using Android Studio V4.1.3. I’d like to use some classes of my Github repos over here: https://github.com/willnerNCP/jULM. I’m using Jitpack to include those into my android project, so in my build.gradle file I have added: dependencies { implementation ‘com.github.willnerNCP:julm:v1.1’ … } allprojects { repositories { google() jcenter() maven { url ‘https://www.jitpack.io’ } } } ..

Read more