Category : android-min-sdk

How can I fix error after changing currentMinSdkVersion in Android build.gradle? I changed currentMinSdkVersion to 24 from 21 to support 3rd party library. After then I tried to build and saw below error message. is also present at [androidx.core:core:1.5.0] AndroidManifest.xml:24:18-86 value=(androidx.core.app.CoreComponentFactory). Suggestion: add ‘tools:replace="android:appComponentFactory"’ to <application> element at AndroidManifest.xml:48:5-518:19 to override.“` —————————————- (1) I tried ..

Read more

I am installing Android app with target sdk version android S in Android phone with Api level 30. My default config settings for app is like compileSdkVersion ‘android-S’ buildToolsVersion "30.0.3" defaultConfig { applicationId "com.example.test" minSdkVersion 21 targetSdkVersion "S" versionCode 1 versionName "1.0" testInstrumentationRunner "androidx.test.runner.AndroidJUnitRunner" } But when I install the apk in Emulator with Api ..

Read more

I am developing a Media Player app and the min API level that I want it to support is API 22. I want to use Audio Focus for the media playback, but the AudioFocusRequest.Builder() doesn’t work on API levels lower than API 26 and the method requestAudioFocus() that used to work on API levels less ..

Read more