Questions tagged android-manifest

Explore the latest questions and answers asked by our top developers.

How to set Android exported for Cordova application

I am need to publish a Cordova application on Google Play targeting Android 12. When I uploaded my APK file, I get error You uploaded an APK or Android App Bundle which has an activity, activity alias, service or broadcast receiver with intent filter, but without the ‘android:exported’ property set. This file can’t be installed […]

By user3523426
Published
Categorized as android, android-manifest, cordova, export

Is there any way to write a string in manifest without using string.xml in android studio?

anyone, please help me write a string in manifest in the android studio without using string.xml. I want to control a string that exists in the manifest from the server using JSON Source: Android Questions

By jenos kon
Published
Categorized as android, android-manifest, string

How do I grant SYSTEM_ALERT_WINDOW permission automatically on request, in my android App?

For context, the Android documentation says that some app classes receive the SYSTEM_ALERT_WINDOW permission automatically on request: Any app that has ROLE_CALL_SCREENING and requests SYSTEM_ALERT_WINDOW automatically receives the permission. If the app misses ROLE_CALL_SCREENING, it loses permission. Any app that is capturing the screen using a MediaProjection and requests SYSTEM_ALERT_WINDOW automatically receives permission, unless explicitly […]

Can’t build apk for Android 12. Cordova

Please help me with a problem When I try to install the application after building it on Android 12 emulator, AndroidStudio throws errors for some services: Failure [INSTALL_PARSE_FAILED_MANIFEST_MALFORMED: Failed pars e during installPackageLI: /data/app/vmdl1492588574.tmp/base.apk (at Binary XML file line #105): com.adobe.phonegap.push.FCMService: Targeting S+ (version 31 and above) requires that a n explicit value for android:exported […]

By
Published
Categorized as android, android-12, android-manifest, apk, cordova

Manifest merger failed with multiple errors,see logs

sorry to disturb but I have tried many answers on internet but every is solving sdk problem my AndroidManifest.xml don’t show any problem and yet my code is not running.please help me and sorry for that much silly question. I am adding image for better understanding Source: Android Studio Questions

By Taiba Fatima
Published
Categorized as android-manifest, android-studio, kotlin

You uploaded an APK or Android App Bundle which has an activity, activity alias, service or broadcast receiver with intent filter, but without the ‘an

Issue : You uploaded an APK or Android App Bundle which has an activity, activity alias, service or broadcast receiver with intent filter, but without the ‘android:exported’ property set. This file can’t be installed on Android 12 or higher. See: developer.android.com/about/versions/12/behavior-changes-12#exported My AndroidManifest.xml file <manifest xmlns:android="http://schemas.android.com/apk/res/android" xmlns:tools="http://schemas.android.com/tools" package="com.c4life.guardianangel"> <uses-permission android:name="android.permission.INTERNET"/> <uses-permission android:name="android.permission.FOREGROUND_SERVICE"/> <uses-permission android:name="android.permission.ACCESS_FINE_LOCATION"/> <uses-permission […]

By Syed Waleed
Published
Categorized as android, android-12, android-manifest

MissingClass : referenced class in the manifest was not found in the project or the libraries

This is what I got during cd android && ./gradlew build –warning-mode all : Here’s my manifest: <manifest package="com.projectTeam.projectName" xmlns:android="http://schemas.android.com/apk/res/android" xmlns:tools="http://schemas.android.com/tools"> <supports-screens android:largeScreens="true" android:normalScreens="true" android:smallScreens="false" android:xlargeScreens="false" tools:replace="android:smallScreens, android:xlargeScreens" /> <uses-permission android:name="android.permission.INTERNET" /> <uses-permission android:name="android.permission.USE_FINGERPRINT" /> <uses-permission android:name="android.permission.VIBRATE" /> <application android:name=".MainApplication" android:label="@string/app_name" android:icon="@mipmap/ic_launcher" android:roundIcon="@mipmap/ic_launcher_round" android:allowBackup="false" android:theme="@style/AppTheme" android:networkSecurityConfig="@xml/network_security_config" > <activity android:name=".MainActivity" android:launchMode="singleTask" android:label="@string/app_name" android:exported="true" android:screenOrientation="portrait" android:configChanges="keyboard|keyboardHidden|orientation|screenSize|uiMode" android:windowSoftInputMode="adjustResize" […]

By Olek
Published
Categorized as android, android-manifest, gradle, react-native

AndroidManifest error: android:exported needs to be explicitly specified for <activity>

When i change target and compile sdk version from 30 to 31 i get error. Something similar I see in this question, but it has no answers. Error: android:exported needs to be explicitly specified for . Apps targeting Android 12 and higher are required to specify an explicit value for android:exported when the corresponding component […]

By Sunbey13
Published
Categorized as android, android-api-31, android-manifest

Manifest merger failed for <receiver> when migrating to android 12 despite adding android: exported flag

I am trying migrating my app to android 12 by changing the target SDK version to 31 in build.gradle. As required, I have added android:exported flag to every activity/receiver/services/provider tags present in my manifest file. But still I am getting this error. Manifest merger failed : android:exported needs to be explicitly specified for <receiver>. Apps […]

By akhil jain
Published
Categorized as android, android-12, android-manifest, android-studio, kotlin

App installation fails in Android 12 devices

Our app fails to install after migrating to the targetSdkVersion 31. On trying to find the issue we found that a library was using FLASHLIGHT permission and we were getting this error while installing: Installation failed due to: ‘Failed to commit install session 130765275 with command cmd package install-commit 130765275. Error: -127: Package com.xxxx.yyyy.zzzz attempting […]

1 2 3 50

Still Have Questions?


Our dedicated development team is here for you!

We can help you find answers to your question for as low as 5$.

Contact Us
faq