Category : android-gradle-plugin

I am getting multiple versions of androidx.annotations (1.0.0, 1.1.0, 1.2.0) in my project. Even after forceful resolution in app level build.gradle file still there are multiple versions. How can I resolve it? I just need a single version (1.2.0) Same is happening with other libs also like (appcompat, androidx.arch.core etc) app level build.gradle configurations.all { ..

Read more

I am using qt and get this error message when build for android. I dont understand why give this. Please help me. Thanks. Initializing deployment to Android device/simulator Deploying to 0123456789ABCDEF 19:04:43: Running steps for project Android_Test… 19:04:43: Starting: "D:PROJECTSIDEQtQt5.12.10.12.10android_armv7binqmake.exe" "D:PROJECTSAll ProjectsQt ProjectsIn ProgressAndroid_TestAndroid_Test.pro" -spec android-clang "CONFIG+=qml_debug" 19:04:44: The process "D:PROJECTSIDEQtQt5.12.10.12.10android_armv7binqmake.exe" exited normally. 19:04:44: Starting: ..

Read more

Our Android project is build with gradle build tools 3.6.2 and gradle-5.6.4-all, with the dexcount-gradle-plugin 1.0.4. (Sadly we can’t update our gradle to use the dexcount-gradle-plugin:2.0.0.) We get the following error when the task countReleaseDexMethods is executed: com.getkeepsafe.dexcount.DexCountException: Unable to run dx –help (file: C:UserscschwarzAppDataLocalAndroidSdkbuild-tools.0.2dx.bat) Note the dx.bat can be found under the path. The ..

Read more

I have a project with the standard java library and this creates several .jar files, one being a docset and another the source set. Now I have successfully created an android-library using the maven-publish plugin, but when I add the .aar files to another project, they don’t contain neither source nor comments as the .jar ..

Read more

I am trying to create a new project in AS Fox Canary 14 but then it inmediately fails with Could not find method dependencyResolutionManagement(). When I check the Gradle version for the created project in gradle-wrapper.properties it is 6.1.1 but the docs state that it is only available since 6.8. When I upgrade it to ..

Read more

Gradle sync error. Please help me to fix this. I Googled it and none of the solutions worked. .groovy.ast.expr.ArgumentListExpression org.codehaus.groovy.ast.expr.TupleExpression cannot be cast to org.codehaus.groovy.ast.expr.ArgumentListExpression Gradle’s dependency cache may be corrupt (this sometimes occurs after a network connection timeout.) Re-download dependencies and sync project (requires network) The state of a Gradle build process (daemon) may ..

Read more

I am using Android Gradle Plugin version 7.0.0-alpha14 and Gradle version 7.0 and when I try to upload the app to app distribution through the Gradle plugin version 2.1.0 it fails on a task app:appDistributionUploadDebug with an error > Task :app:appDistributionUploadDebug FAILED FAILURE: Build failed with an exception. * What went wrong: Some problems were ..

Read more

In my React Native project I’m using [email protected], and following the migration guide from a previous version, I have the following line in my android/build.gradle file: classpath(‘com.android.tools.build:gradle:4.1.3′) When I recently opened the project in Android Studio it recommended I upgrade my Android Gradle Plugin from 4.1.2 to 4.1.3. What I Want To Know: What’s the ..

Read more