Flutter -> Could not resolve com.google.firebase:firebase-messaging:[10.2.1, 17.3.99]

  android, build.gradle, firebase, flutter, onesignal

I can’t compile my project because of this:

FAILURE: Build failed with an exception.


* What went wrong:
Could not determine the dependencies of task ':app:compileDebugJavaWithJavac'.
> Could not resolve all task dependencies for configuration ':app:debugCompileClasspath'.
   > Could not resolve com.google.firebase:firebase-messaging:[10.2.1, 17.3.99].
     Required by:
         project :app > com.onesignal:OneSignal:3.15.3
      > Failed to list versions for com.google.firebase:firebase-messaging.
         > Unable to load Maven meta-data from https://jcenter.bintray.com/com/google/firebase/firebase-messaging/maven-metadata.xml.
            > Could not get resource 'https://jcenter.bintray.com/com/google/firebase/firebase-messaging/maven-metadata.xml'.
               > Could not GET 'https://jcenter.bintray.com/com/google/firebase/firebase-messaging/maven-metadata.xml'.
                  > Read timed out
   > Could not resolve com.google.android.gms:play-services-ads-identifier:[15.0.0, 16.0.99].
     Required by:
         project :app > com.onesignal:OneSignal:3.15.3
32
      > Skipped due to earlier error
   > Could not resolve com.google.android.gms:play-services-base:[10.2.1, 16.1.99].
     Required by:
         project :app > com.onesignal:OneSignal:3.15.3
32
      > Skipped due to earlier error

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 3m 49s

last night the project was working nice. Old commits show the same erro when i run

Source: Android Questions

LEAVE A COMMENT