A problem occurred evaluating project ‘:cloud_firestore’

I develop a Flutter project with my team members. I recently pulled from github and it gave this error. However, my friends do not have the same problem and do not get error from the same code.

I get either that error

FAILURE: Build failed with an exception.

Where:
Build file 'C:developmentflutter.pub-cachehostedpub.dartlang.orgcloud_firestore-0.16.0androidbuild.gradle' line: 41

What went wrong:
A problem occurred evaluating project ':cloud_firestore'.
build_2yq8w8slntfd1pcrdfbqqhulb$_run_closure2$_closure4

or that one

FAILURE: Build failed with an exception.

* Where:
Build file 'C:developmentflutter.pub-cachehostedpub.dartlang.orgcloud_firestore-0.16.0androidbuild.gradle' line: 41

* What went wrong:
A problem occurred evaluating project ':cloud_firestore'.
> Incompatible magic value 0 in class file build_2yq8w8slntfd1pcrdfbqqhulb$_run_closure2$_closure4

Lines of codes in build.gradle as follows

39   android {
40     compileSdkVersion  29
41     compileOptions {
42         sourceCompatibility JavaVersion.VERSION_1_8
43         targetCompatibility JavaVersion.VERSION_1_8
44     }

What would be the solution? I appreciate your help.

Whole build.gradle


group 'io.flutter.plugins.firebase.cloudfirestore'
version '1.0-SNAPSHOT'

buildscript {
    repositories {
        google()
        jcenter()
        mavenLocal()
    }

    dependencies {
        classpath 'com.android.tools.build:gradle:3.5.4'
    }
}

allprojects {
    repositories {
        google()
        jcenter()
        mavenLocal()
    }
}

apply plugin: 'com.android.library'

def firebaseCoreProject = findProject(':firebase_core')
if (firebaseCoreProject == null) {
    throw new GradleException('Could not find the firebase_core FlutterFire plugin, have you added it as a dependency in your pubspec?')
} else if (!firebaseCoreProject.properties['FirebaseSDKVersion']) {
    throw new GradleException('A newer version of the firebase_core FlutterFire plugin is required, please update your firebase_core pubspec dependency.')
}

def getRootProjectExtOrCoreProperty(name, firebaseCoreProject) {
    if (!rootProject.ext.has('FlutterFire')) return firebaseCoreProject.properties[name]
    if (!rootProject.ext.get('FlutterFire')[name]) return firebaseCoreProject.properties[name]
    return rootProject.ext.get('FlutterFire').get(name)
}

android {
    compileSdkVersion 29
    compileOptions {
        sourceCompatibility JavaVersion.VERSION_1_8
        targetCompatibility JavaVersion.VERSION_1_8
    }
    defaultConfig {
        minSdkVersion 16
        testInstrumentationRunner "androidx.test.runner.AndroidJUnitRunner"
    }
    lintOptions {
        disable 'InvalidPackage'
    }
    dependencies {
        api firebaseCoreProject
        implementation platform("com.google.firebase:firebase-bom:${getRootProjectExtOrCoreProperty("FirebaseSDKVersion", firebaseCoreProject)}")
        implementation 'com.google.firebase:firebase-firestore'
        implementation 'androidx.annotation:annotation:1.1.0'
    }
}

apply from: file("./user-agent.gradle")

Source: Android Questions

LEAVE A COMMENT